• 总部联系方式    

    总部电话:021-51212121

    总部传真:021-51212480(自动)/021-51212481(人工)

    服务热线:400-628-6280

    邮箱:support@huagai.com

    地址:上海市闸北区江场西路299弄中铁中环时代广场4号楼4层

    邮编:200436

    路线图:

  • Vigor与Cisco路由器连IPSEC VPN 浏览次数:7566 次   浏览时间:2017/10/20 22:29:26

  • 一.Cisco VPN配置步骤

    1.      配置IKE

    router(config)# crypto isakmpenable         #启用IKE(默认是启动的)
    router(config)# crypto isakmp policy 100     #建立IKE策略,优先级为100
    router(config-isakmp)# authentication pre-share    #使用预共享的密码进行身份验证
    router(config-isakmp)# encryption des      #使用des加密方式
    router(config-isakmp)# group 1      #指定密钥位数,group 2安全性更高,但更耗cpu
    router(config-isakmp)# hash md5       #指定hash算法为MD5(其他方式:sha,rsa)
    router(config-isakmp)# lifetime 28800   #指定SA有效期时间。默认86400秒,两端要一致
    以上配置可通过show crypto isakmp policy显示。VPN两端路由器的上述配置要完全一样。

     

    2:配置Keys
    router(config)# crypto isakmp key 123456 address0.0.0.0 0.0.0.0 --(设置要使用的预共享密钥和指定vpn另一端路由器的IP地址,如对端是动态IP,全0即可)

    3.:配置IPSEC
    router(config)# crypto ipsec transform-set abcesp-des esp-md5-hmac   
    配置IPSec交换集
                    abc这个名字可以随便取,两端的名字也可不一样,但其他参数要一致。
    router(config)# crypto ipsec security-association lifetime 3600  
                    ipsec安全关联存活期,也可不配置,在下面的map里指定即可
    access-list101 permit ip 10.0.0.0 0.0.0.255 172.31.1.0 0.0.0.255

    定义感兴趣流
    4.配置IPSEC加密映射
    router(config)# crypto map vigor 100 ipsec-isakmp  创建加密图
    router(config-crypto-map)# match address 101   用ACL来定义加密的通信
    router(config-crypto-map)# set peer x.x.x.x  标识对方路由器IP地址
    router(config-crypto-map)# set transform-set abc  指定加密图使用的IPSEC交换集
    router(config-crypto-map)# set security-association lifetime 3600
    router(config-crypto-map)# set pfs group 1        和Vigor一致

     

    5.创建IPSEC策略

    router(config)#crypto map vigor 100ipsec-isakmp dynamic vigor

    6.应用加密图到接口
    router(config)# interface ethernet0/1           外网出接口
    router(config-if)# crypto map vigor            调用新建IPSEC

    7.本地10.0.0.0 0.0.0.255到172.31.1.00.0.0.255不做NAT转换

     

    二.     Vigor配置

    1. 定义文档名ljbbj

    启用该文档名

    Vpn对端地址为X.X.X.X          //思科路由器的外网接口地址

    密钥为:123456                         //和思科路由器对应

    服务器内型为ipsec隧道

    2


    2.IPSEC第一阶段和第二阶段设置


    3.感兴趣流



上一篇:如何登陆Vigor路由器? 下一篇:Vigor3300系列还原出厂值